Radio dead after MMI update (5150/5570)

Discussion in 'MMI' started by A6tdi, May 16, 2010.

  1. A6tdi New Member

    After trying to upgrade from version 0500 to 5570 (two steps 0500-->5150-->5570) the radio now is dead.

    The update first started good, but then several error messages saying "read error" occurred.

    If I am trying to use radio it says "not installed".

    I have tried to re run the update (5150) but now it says metainfo canot be anaysed, same error message for the 1110 update.


    A6, 2.0 TDI, No SDS in car, only NAV, Radio + CD changer (MMI high)

    Any ideas for this error ?
  2. Google

  3. a8 tech Member

    can you see address 56 with vcds?
    run the optical test function with vcds and post the results
  4. A6tdi New Member

    I dont have vcds or vagcom, but it looks like i have to get one...
  5. a8 tech Member

    yep it will shed some light on the failure as the radio rarely fails and most common failures are hw version 16 phone prep.
  6. A6tdi New Member

    The Vagcom cable arrived today, an the errors are:


    07-Control Head -- Status: Malfunction 0010
    19-CAN Gateway -- Status: Malfunction 0010
    37-Navigation -- Status: Malfunction 0010
    56-Radio -- Status: Cannot be reached 1100
    61-Battery Regul. -- Status: Malfunction 0010



    Address 07: Control Head Labels: 4F0-910-7xx-07-H.lbl
    Part No SW: 4F0 910 729 Q HW: 4E0 035 729
    Component: Interfacebox H43 0500
    Revision: 00000000 Serial number: 350KS047554048
    Coding: 0000002
    Shop #: WSC 02325 785 00200

    Part No: 4F0 910 609
    Component: Bedienteil MMIC6H07 0870

    1 Fault Found:
    01317 - Control Module in Instrument Cluster (J285)
    004 - No Signal/Communication - Intermittent
    -----------------------------------------------------------------------------
    Address 19: CAN Gateway Labels: 4F0-910-468.lbl
    Part No SW: 4F0 910 468 A HW: 4F0 907 468 B
    Component: Gateway H09 0030
    Revision: 09 Serial number: 0800804B190389
    Coding: 6CEE73C41B2104
    Shop #: WSC 02325 785 00200

    1 Fault Found:
    01304 - Radio
    004 - No Signal/Communication

    -------------------------------------------------------------------------------

    Address 56: Radio
    Cannot be reached

    *****************************************************
    -------------------------------------------------------------------------------
    Address 37: Navigation Labels: 4E0-910-88x-37.lbl
    Part No SW: 4E0 910 888 P HW: 4E0 919 887 C
    Component: MNS ECE H43 1060
    Revision: 00000000 Serial number: 353K.047593087
    Shop #: WSC 02325 785 00200

    1 Fault Found:
    02927 - DVD Read Error
    000 - - - Intermittent
    -----------------------------------------------------------------------
    Address 61: Battery Regul. Labels: 4F0-910-181.lbl
    Part No SW: 4F0 910 181 E HW: 4F0 915 181 A
    Component: ENERGIEMANAGER H11 0490
    Revision: 00000000 Serial number: 00000000086798
    Shop #: WSC 00040 218 55118

    Part No: 4F0 915 105 D
    Component: von VA0 1411180464
    Coding: 344630393135313035442056413031343131313830343634
    Shop #: WSC 00000 384 00290

    1 Fault Found:
    02256 - Quiescent Current
    001 - Upper Limit Exceeded - Intermittent



    Any help in this ?
  7. A6tdi New Member

    As you asked for the optical scan:

    Control Module Part Number: 4F0 910 468 A
    Component and/or Version: Gateway H09 0030

    Optical Bus Diagnostic : Standard

    Controller Electrical Optical
    19-CAN Gateway OK OK
    07-Control Head(High/D3) OK OK
    0E-Media Player 1 OK OK
    47-Sound System OK OK
    56-Radio ERROR ERROR
    37-Navigation OK OK
  8. craigyb Active Member

    Pretty conclusive that the radio is broken. I woukd just buy another from Ebay, the yare about 200 euros.
  9. a8 tech Member

    yep radio goosed
  10. neo_andersson Member

    It happened to my Q7 as well during update. I solved by removing the circuit braker for the radio, left it without power for a few minutes, then pluged it back.

    After that i started the update CD1 and found that Radio had SW Version 0000. Update went smooth and radio came back to life.

    Hope you have the same problem that can be solved this way sparing you of spending 200 euros.
  11. A6tdi New Member

    Thanks for help.

    I would like to try to test the crikut breaker / fuse before I ordering a new one, but can't find the right fuse, there is some marked comunicatinon, but no radio. Any idea for a fuse to try ?
  12. craigyb Active Member

    Why not just pull the power cable on the radio.

    I must admit that I once trashed a radio during an update, swapped it with another, then later updated the broken radio ok on my test bench.
  13. A6tdi New Member

    It's a easy to take the fuse, I don't tink I can pull the cable without disassembling the rack with the K-box (A6), but I may disconnect the battery ...

    If I buy a K-box, is all versions useable ?
  14. rlarsen Member

    What does your Owner's manual say about the Fuse list?? - on my A4 I have fuses with the names "MMI/Radio" and "Radio/navigation".
  15. neo_andersson Member

    I am not sure if all versions will work in your car but if you send me a PM with your VIN i can take the information from ETKA.
  16. A6tdi New Member

    There is no "Radio", just some marked "comunication" i tried them today and the adress for the radio disapear for one of these. I have not tried the vagcom after this, but the radio is still " not installed"

    There are several K-box versions out there (eg. L after part nr.) can all of them be mixed in my system ?
  17. A6tdi New Member

    New K-Box in car

    My new k-box arrived today, and it's now in my car, working fine.

    The next step is to try getting a bluetooth unit without upgrading the MMI system !

    There's possible 2 options:
    *Dension 500 with the BTA1500 bluetooth adapter
    *Viseeo MOSTO (tech suport is sorting out abt. MMI versions)

    Someone have other suggestions?
  18. Oracle New Member

    Same issue happened to me trying to update my 05 A6. Trying to locate a k-box for my car but they seem scarce currently. Any suggested resources I can try besides eBay? Dealer was talking $800 to which I literally cracked up laughing.
  19. kris.2010 Member

    hello, we have k.box radio unit
    >> cost 150 euro incl. inside latest firmware 620

    kris

Share Audi Forum with friends