MMI3G+ retrofit - 2007 Q7 - Hidden menu help...

Discussion in 'MMI' started by spyderboyant, Feb 27, 2016.

  1. spyderboyant Member

    Hi there,

    wondering if anyone could help me. I've retrofitted an MMI3G+ into my 2007 Q7. Everything works great (external and internal lighting switches, Parking aid stuff etc..) except a few menu options are greyed out and state "currently not available". I'm wondering whether I have some of the hidden menu settings set incorrectly or whether these options may not be possible due to the older hardware in my car?

    What I'm talking about is:
    1) Car/Driver Assist. "Speed warning" "speed limit display" and "Gear Recommendation". Parking aid IS WORKING perfectly.
    2) Servicing and checks - Vin and service schedule not working. Wiper blade lock does work however.
    3) Cannot set the clock.... All menu options greyed out.

    Everything that I have got working I've had to set in 'carbusassignment' to [Clamp 15]

    I'm just wondering whether something might be missing from my wiring as I think the functions above need to get the information from the cluster via the [CAN Dashboard]? Having said that, I don't know what the [Clamp 15] bus is? All I can imagine is that its related to the MOST bus as this is the way the MMI3G+ connects to the CAN gateway as with version 3 from version 2 of MMI the dedicated infotainment CAN is not wired (see attached wiring diagram).

    Below is a capture of the carbusassignment and also

    <EM 1.0t> /car/carbusassignment
    Air Condition [Clamp 15] 8/9
    Auxiliary Heating [Clamp 15] 8/9
    Headup display [unspecified] 9/9
    Adaptive cruise control [unspecified] 9/9
    Suspension [unspecified] 9/9
    Tyre pressure control (RDK) [unspecified] 9/9
    Interior Light [Clamp 15] 8/9
    Exterior Light [Clamp 15] 8/9
    Park Distance Control [Clamp 15] 8/9
    Rearview Camera [Clamp 15] 8/9
    Wiper [Clamp 15] 8/9
    Doorlocking [Clamp 15] 8/9
    Mirror [Clamp 15] 8/9
    On-board computer [Clamp 15] 8/9
    Seat memory front [Clamp 15] 8/9
    clock [Clamp 15] 8/9
    service intervall [Clamp 15] 8/9
    central units master (ZEM) [Clamp 15] 8/9
    univ. garage door opener [unspecified] 9/9
    Compass [unspecified] 9/9
    Charisma [unspecified] 9/9
    Night Vision [unspecified] 9/9
    Lane departure warning (HCA) [unspecified] 9/9
    Lane change assist (SWA) [unspecified] 9/9
    Braking way reduction (AWV) [CAN Extended] 5/9
    Hybrid [CAN Antrieb] 3/9
    Sideview camera [unspecified] 9/9
    rev. seat-belt tensioner (RGS) [unspecified] 9/9
    Traffic sign recognition (VZE) [unspecified] 9/9
    Rear seat entertainment [unspecified] 9/9
    Vehicle IdentNo activate (VIN) [Clamp 15] 8/9
    Oil level gauge [unspecified] 9/9
    Weariness recognition (MKE) [unspecified] 9/9
    Tilt angle display [unspecified] 9/9
    Seat Heat [CAN Komfort] 1/9

    <EM 1.0t> /car/carmenuoperation
    … VALUE
    Adaptive Cruise control 0
    Interior light 5
    Parking system: 5
    Braking way reduction (AWV): 0
    Lane departure warning (HCA): 0
    Lane change assist (SWA): 0
    Exterior light: 5
    Battery level gauge 0
    Window: 5
    air condition: 7
    on-board computer: 5
    Tyre pressure control (RDK) 0
    Wiper: 9
    Service intervall: 5
    Seat memory: 1
    Central lock system 5
    Compass: 0
    Charisma 0
    Oil level gauge 0
    Vehicle IdentNo activate (VIN) 1
    clock 5
    Suspension 0
    Headup display 0
    Central units master (ZEM) 7
    Hybrid: 0
    Bord book: 0
    univ. garage door opener 0
    night vision: 0
    Sideview camera: 0
    rev. seat-belt tensioner (RGS) 0
    MFL joker key: 0
    Auxiliary heating: 5
    Traffic sign recognition (VZE): 0
    Rear seat entertainment 0
    Weariness recognition (MKE): 0
    Programmed Key (Ang. Schl): 0
    Tilt angle display: 0

    Attached Files:

  2. Advertisement

  3. NikolasZ Member

    Did you get any help with this?
    In the green meny under Car, go to submenu carprotocolswitch.
    DE-SELECT the following:
    • ParkDistance control
    • On-board computer
    • Clock
    • Service Intervall
    If you have the ABS-sensor TPMS (PR-7K6), then you should also deselect "Tyre Pressure Control (RDK) in the same menu.

    You carbusassignment is completely off and wrong. Should be:
    <EM 1.0t> /car/carbusassignment
    Air Condition [CAN Comfort] 1/9
    Auxiliary Heating [CAN Comfort] 1/9
    Headup display [unspecified] 9/9
    Adaptive cruise control [CAN Extended] 5/9
    Suspension [CAN Antrieb] 3/9
    Tyre pressure control (RDK) [CAN Antrieb] 3/9 NOTE! If you have ABS-sensored TPMS
    Tyre pressure control (RDK) [CAN Komfort] 1/9 NOTE! If you have wheel based sensor TPMS
    Interior Light [CAN Komfort] 1/9
    Exterior Light [CAN Komfort] 1/9
    Park Distance Control [Clamp 15] 8/9
    Rearview Camera [CAN Komfort] 1/9
    Wiper [CAN Komfort] 1/9
    Doorlocking [CAN Komfort] 1/9
    Mirror [unspecified] 9/9
    On-board computer [CAN Dashboard] 2/9
    Seat memory front [CAN Komfort] 1/9
    clock [CAN Dashboard] 2/9
    service intervall [CAN Dashboard] 2/9
    central units master (ZEM) [CAN Dashboard] 2/9
    univ. garage door opener [unspecified] 9/9
    Compass [unspecified] 9/9
    Charisma [unspecified] 9/9
    Night Vision [unspecified] 9/9
    Lane departure warning (HCA) [CAN Extended] 5/9
    Lane change assist (SWA) [CAN Extended] 5/9
    Braking way reduction (AWV) [CAN Extended] 5/9
    Hybrid [CAN Antrieb] 3/9
    Sideview camera [unspecified] 9/9
    rev. seat-belt tensioner (RGS) [unspecified] 9/9
    Traffic sign recognition (VZE) [unspecified] 9/9
    Rear seat entertainment [unspecified] 9/9
    Vehicle IdentNo activate (VIN) [CAN Komfort] 1/9
    Oil level gauge [unspecified] 9/9
    Weariness recognition (MKE) [unspecified] 9/9
    Tilt angle display [unspecified] 9/9
    Seat Heat [CAN Komfort] 1/9

    Good luck!
  4. NikolasZ Member

    You have some more faulty settings in the carmenuoperation part: (marked in bold)
    <EM 1.0t> /car/carmenuoperation
    … VALUE
    Adaptive Cruise control 0
    Interior light 5
    Parking system: 1
    Braking way reduction (AWV): 0
    Lane departure warning (HCA): 0
    Lane change assist (SWA): 0
    Exterior light: 5
    Battery level gauge 0
    Window: 5
    air condition: 7
    on-board computer: 5
    Tyre pressure control (RDK) 0
    Wiper: 9
    Service intervall: 7
    Seat memory: 1
    Central lock system 5
    Compass: 0
    Charisma 0
    Oil level gauge 0
    Vehicle IdentNo activate (VIN) 5
    clock 7
    Suspension 0
    Headup display 0
    Central units master (ZEM) 7
    Hybrid: 0
    Bord book: 3
    univ. garage door opener 0
    night vision: 0
    Sideview camera: 0
    rev. seat-belt tensioner (RGS) 0
    MFL joker key: 0
    Auxiliary heating: 5
    Traffic sign recognition (VZE): 0
    Rear seat entertainment 0
    Weariness recognition (MKE): 0
    Programmed Key (Ang. Schl): 0
    Tilt angle display: 0
  5. spyderboyant Member

    thanks for the reply. I have had a play around and I definitely cannot use any other bus protocol except [clamp 15]. When I change for instance "Seat memory front [Clamp 15] 8/9" to [Can Komfort] the option for setting the key memory for the front seat becomes greyed out and the MMI states its "not available". The moment I switch it back it works again in the MMI3GP. I am wondering because my car was a 2007 Q7, most of the components can only be accessed via [Clamp 15] CAN commands as these components are not directly MMI 3G+ compatible. I know the J519 Komfot module should be MMI3G compatible as I replaced it with the facelift version to control the LED DRLs and turn indicators BUT AGAIN, on [clamp 15] works. When I change to [CAN Komfort] all the options are greyed out again...

    I am starting to think that some of the speed setting options that are not available in the MMI may be due to the fact that my Instrument Cluster is the ACC version and I may only be able to get the ACC settings from it via the MMI. I'll be retrofitting ACC in the next few weeks and will be able to see if my theory is correct.

    VIN is not available do to the use of the Carson patch for the SatNav maps.

    What car and year did you pull those settings from?

    What is interesting is for the wiring for the MMI3GP there is NO wired CAN bus for the Q7 (MMI2G High had Entertainment CAN high and low). All communications occur over the MOST to the CAN Gateway. My CAN Gateway is the 26 pin "A" version for ACC which I have flashed to 0071 firmware which works with the MMI3GP in that I can see and scroll through all the settings via the stalk on my steering wheel and everything is displayed correctly in the cluster DIS. I know some people state that the open diagnostic circuit wire should be the "CAN High" wire so I've swapped these two around but it makes no difference (used the "CAN High Entertainment").
  6. NikolasZ Member

    Hi,
    The setting come from both my car (2011 Q7 with retrofitted MMI 3G+) and a factory fitted MMI 3G+ from a 2015 Q7. (They have the same settings!)

    Did you look at the carprotocolswitch settings?
    I experienced myself that selecting all the options in the menu gave me they grey options for the Speedwarning and also made the Speed Limit Display and Gear Recommendation appear. Those two last options should not appear on our cars. Also gives the gray options for the clock settings. I bet the clock doesn't even appear on the bottom middle on you MMI-screen.
    So you have to deselect:
    • ParkDistance Control
    • On-board computer
    • Clock
    • Service Intervall

    Yes, the MMI 3G and 3G+ does not have any CAN-bus connection. All this communication is over the MOST-bus, to which the Gateway translates all the different CAN-buses to/from MOST.
    So the fact that you need to have most of your carbusassignment settings to Clamp 15, is probably due to that you have the old 26-pin Gateway in your car. (even though you flashed it...).
  7. spyderboyant Member

    Thanks for the reply. So you are saying that the clock should appear if I deselect this protocol switch items?

    And yes, my clock is greyed out. Should I be able to get it to work with the older 26pin gateway. If I go the 20 pin gateway I will have to wire up a new battery monitoring circuit to the gateway which I am not keen on but have seen that it is achievable.
  8. spyderboyant Member

    When I deselect Parkdistance from protocol switch I lose my rear view camera display. I think there must be a difference between the 26pin CAN AND 20 pin when dealing with the 3gp.... Hence the reason I can only use (clamp 15) in the bus settings to get anything to work
  9. spyderboyant Member

    Hi Nikolas,

    can you PM me your MMI screens from your Q7 so I know what should and shouldn't work? I still have those settings greyed on my "Driver Assist" section - "Speed warning, Speed limit display", "Gear recommendation on"

    Many thanks
    A
  10. 4F-Devil Member

    I think, your problem is the old gateway.
    I switchd always my mmi2g to 3gp - everythink works great without errors.
    I have also cornerview activ - without problems in my old A6 4F mj 2006.
  11. spyderboyant Member

    I think so to. Which gateway did you install for 3GP to work 100%? 4F0907468G with N firmware (0035)? My understanding is for 3G the following list of 26 pin Extended CAN gateways can be used:

    26-pin:
    4L0 907 468 A, SW: 4L0 910 468 A Firmware (0071)
    4L0 907 468 C, SW: 4L0 910 468 A firmare (0071)

    20-pin: (you will need this if you want to go to 3G+)
    4F0 907 468 G, SW: 4F0 907 468 G Firmware: 0022, 0024 (2008)
    4F0 907 468 G, SW: 4F0 907 468 L Firmware: 0025 (2009)
    4F0 907 468 G, SW: 4F0 907 468 N Firmware: 0035 (2010) <<<< MMI 3G+ this is minimum version!

    Following the .SGI file doesn't seem to be available..
    4F0 907 468 G, SW: 4F0 907 468 Q Firmware: 0047 (2010)
    4F0 907 468 G, SW: 4F0 907 468 S Firmware: 0057 (2012)
    4F0 907 468 G, SW: 4F0 907 468 S Firmware: 0058 (2013)

    You will need at least N revision to go to 3G+. Any 4F0 907468 G can be flashed up to version N with firmware 0035.

    i will need to make a 26pin to 20pin harness and see if it works... Unfortunately moving from 26pin to 20pin gateway I need to re-wire Battery Energy Management (BEM) :-(
  12. 4F-Devil Member

    The minimum software version is 35.
    Yes, you need to replace the alternator and the battery management.

Share Audi Forum with friends