Change SDS language MMI 3G

Discussion in 'MMI' started by javii, Feb 19, 2010.

  1. javii Member

    Hi, after retrofitting MMI 3G into my A4 B8, I need to change SDS language, I've playing around with the hidden menu but it doesn't let me change SDS language to es_ES.

    any idea?

    [​IMG]
  2. Google

  3. javii Member

    BTW my 5f unit comes from an A5 Cabrio, I have read somewhere Audi cabrios comes with SDS disabled by default...

    any help would be appreciated
  4. local3 New Member

    Thanks for posting this javii. It would be great to get to the bottom of this.

    I wonder if it is just a matter of coding/adaptation, or some SVM activation similar to component protection (that requires dealer attention and is probably impossible without Audi permission which they won't give) - or perhaps even RNS-E-like different software/different part number question...

    I wrote a piece on this a while ago and it still lacks the definite answer for A5 Cab!

    Is it possible to enable voice control/speech dialogue system in an Audi cabriolet? (A3/A4 B7/A5/S5/TT/R8)
    http://a6retrofit.tripod.com/articles/cabrioletvoicecontrol.html
  5. javii Member

    it worked!

    You were right local3. It was coding.

    This is an example of a 5F coding: 01010001010681ED01002B1E000000010000

    The bold "1" means SDS on. I had a "0" before.

    After changing that, you need to car, setup, change the language to a differente one, and then change it back to your language. Now SDS is enabled and working \\:D/

    I'm sure it will work on A5 cab as well.
  6. local3 New Member

    Great! Thanks!
  7. TDN S5 New Member

    Didn't work for me :-(

    Hi,

    The 5F code in my 2010 S5 cabriolet is 010101030206A1ED45000B1E000000010100 already. As you can see there is already a 1 in the correct place but no SDS.

    Javii, how did you find that it was that change that made the difference? Just trial and error?
  8. Hi
    have you MMI NAvigationsystem with DVD ?

    if yes, then you need the language CD and you can change it easily in the car setup !

    Regards
    CMS
  9. HAWKiS5 Member

    Activing SDS in A5/S5 cabrio is not working

    My car already had this same bit set to "1" from the start (so from factory). No SDS possible however (pressing the steering wheel button results in "No function" message on DIS. Changing it back to "0" and then again to "1" (and in the mean time changing MMI languages) does not result in anything.

    Pity, Hope somebody comes up with the real solution for this.

    (BTW: in the hidden menu I see SDS OFF also in main/config)
  10. qmis New Member

    S5 Cab - SDS

    Hi - Did you manage to get the SDS working? I have a similar code in my 5F module.
  11. mharris561 New Member

    it's bit 16

    bit 16 has to be changed from01 to 00. then the hidden menu access by enabling it with a vag-com the languages scrolled through but not changed and then it should work
  12. gsmdenis New Member

    i am also interesting on this function , but i dunno why my B8 5F code just like this 01010001010681ED01002B1E00000001 , but javii 5F code have more 2 bytes 01010001010681ED01002B1E000000010000, i try to recoding Long Coding, but no coding rejected. hope someone can help around , big thanks

    BR.,

    Denis
    • Premium Supporter

    PetrolDave Super Moderator

    With these extremely long long coding values can I make a plea?

    When posting please separate them into 4 character (2 byte) groups to make them more readable.
  13. S-Tdi New Member

    Any news to this matter? I am struggling myself with the same issue on my A6 4F with 3G.

    The SDS function seems to be working but does not recognize any commands. But if I shout HELP! then it reacts. But nothing more than showing me the help functions.
  14. leo62 New Member

    Hey S-Tdi !
    Sorry to blow this old thread alive again but ...
    Have you already solved this issue, I have exactly same strange behaviour with SDS, if I yell like MEDIA ! it will react accordingly, but not with normal telephone conversation tone given commands ? Phoning with BT works fine fine.
    BR
    LEo

Share Audi Forum with friends